This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.

XT10 LCD switching on and off continously

Discussion in 'X-T2, X-T1, X-T20, X-T10' started by Frem, Jul 15, 2017.

  1. Frem

    Frem New Member

    Joined:
    Aug 22, 2015
    Messages:
    25
    Likes Received:
    3
    Location:
    UK

    -Return to Top-

    Any ideas?
    When I switch on the XT10 within 2 seconds the LCD switches on and off continuously. None of the buttons, including the shutter, work.
    I've swapped batteries over and taken the lens off and cleaned up the contacts but still have the problem. Unfortunately, I only have one autofocus lens so can't test it to see if its a lens issue or the body.
    Has anyone come across this before?
    Thanks.
     
  2. ryanlio

    ryanlio Premium Member

    Joined:
    Apr 6, 2015
    Messages:
    364
    Likes Received:
    199
    Location:
    texas

    -Return to Top-

    May be LCD component issue.
    Just an initial diagnose. Maybe try to switch to evf only .. see if normal shooting works with lens..
     
  3. Goldingd

    Goldingd Premium Member

    Joined:
    Jan 20, 2014
    Messages:
    592
    Likes Received:
    141
    Location:
    Anaheim CA

    -Return to Top-

    Sounds very much like a call Fujifilm issue.

    Incidentally, how does it behave with no lens attached.
     
  4. Frem

    Frem New Member

    Joined:
    Aug 22, 2015
    Messages:
    25
    Likes Received:
    3
    Location:
    UK

    -Return to Top-

    Just been informed by the insurance company that it is beyond economical repair and they're paying out the full purchase price even though I've had it for nearly 2 years. Unfortunately they couldn't tell me what was wrong with it.
    What to buy next..............
     

Share This Page