This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.

X E2S Pop Up Flash/ (H)-(l) Issue

Discussion in 'X-E1, X-E2, X-E2S and X-E3' started by Thomas Millard, Mar 12, 2018.

  1. Thomas Millard

    Thomas Millard New Member

    Joined:
    Mar 12, 2018
    Messages:
    3
    Likes Received:
    0

    -Return to Top-

    Hello,
    Glad to be a member of Fuji's growing family. I am in the process of defecting from Canon after nearly 40 years and moving to the light of Fuji. However, I am having a few issues. I recently purchased an X E2s a few days back and while in 99% of the shooting experience, she has performed above and beyond. However, the 'pop-up' flash does not seem to want to work in manual modes, only in the automated SR mode. Granted, it is highly unlikely that I will ever use this flash with any serious shooting situation, still, I want to know that I can utilize the flash should I find myself in a situation where I would have to employ it. As I said, it works fine in the SR mode, however, upon returning to manual mode it ceases to function nor is there any flash icon on the screen When in the main menu in the Flash Setup section, I have 3 selections..

    1 Flash Mode
    2 Flash Compensation
    3 Red Eye Removal

    #2 and #3 work, but, #1 does not, I can not scroll up to #1, I am forced to #2 and #3.

    Pressing the Disp/Back button, I scroll down to Fn5 for the Flash Mode, press OK and nothing, simply returns to the previous page.

    My second problem. Like the pop-up problem, I do not see myself using this function often if at all, however, I can not seem to access the higher ISO (H)-(L) levels, both are greyed out.

    Problems aside, I am very happy to be apart of this community and look forward to additional Fuji hardware in the coming months.

    Thomas
     
  2. mikEm13

    mikEm13 Premium Member

    Joined:
    Mar 18, 2016
    Messages:
    671
    Likes Received:
    231
    Location:
    Southwest USA

    -Return to Top-

    Im trying to remember how my X-E2s worked. I believe that when in manual mode you have to pop up the flash manually.
     
  3. Thomas Millard

    Thomas Millard New Member

    Joined:
    Mar 12, 2018
    Messages:
    3
    Likes Received:
    0

    -Return to Top-

    Indeed, you still do. As I said it works fine in Auto SR mode, but manual, no-go.
     
  4. mikEm13

    mikEm13 Premium Member

    Joined:
    Mar 18, 2016
    Messages:
    671
    Likes Received:
    231
    Location:
    Southwest USA

    -Return to Top-

    Oh your saying the flash doesn't go off at all. Sorry I cant help you.
     
  5. dem

    dem Premium Member

    Joined:
    May 31, 2015
    Messages:
    782
    Likes Received:
    423
    Location:
    UK

    -Return to Top-

    Is electronic shutter enabled?

    The flash can only work with mechanical shutter. The electronic shutter also stops you from using extended ISO.
     
  6. Thomas Millard

    Thomas Millard New Member

    Joined:
    Mar 12, 2018
    Messages:
    3
    Likes Received:
    0

    -Return to Top-

    Yep, that was the problem with both issues.
     

Share This Page

  1. fujix-forum.com uses cookies to help personalize content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice