This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.

Arsenal - a review after one week

Discussion in 'General Photography Discussion' started by Richard_R, Aug 14, 2018.

  1. BillC-PA

    BillC-PA Premium Member

    Joined:
    Sep 7, 2013
    Messages:
    1,128
    Likes Received:
    612
    Location:
    North of Philadelphia - Bern Township

    -Return to Top-

    Thanks for the information ..... just cancelled my pre-order. (I have enough photographic 'junk' already, don't need anymore)
     
  2. SquarePeg

    SquarePeg Hear me roar

    Joined:
    Jul 28, 2017
    Messages:
    351
    Likes Received:
    929

    -Return to Top-

    Ads for this have been popping up in my Facebook and Instagram feeds at an annoying rate. Was wondering if I was missing something - thanks for the info that I can continue to ignore this gadget.
     
  3. Richard_R

    Richard_R Eclectic eccentric Staff Member

    Joined:
    Dec 10, 2011
    Messages:
    8,410
    Likes Received:
    9,254
    Location:
    Melbourne, Australia

    -Return to Top-

    Firmware version 0.9.16 has been released with claims that it supports the X-T1. I have not tried it and the only comment about it I have seen on the web indicates that the camera still does not work with Arsenal. I might try it over the weekend as the weather is looking pretty ordinary at this stage.
     
    BillC-PA likes this.
  4. Vaibhav

    Vaibhav New Member

    Joined:
    Dec 15, 2014
    Messages:
    92
    Likes Received:
    2
    Location:
    Canterbury, UK

    -Return to Top-

    I faced the exact same experience on my X-T1 and have parked the device in a corner. Maybe I'll open it next year to see if any updates have helped. Guess Ryan and team were too aggressive and did not really understand the complexities of multiple platforms of cameras and phones!!!!
     
  5. Eric Myers

    Eric Myers New Member

    Joined:
    Aug 12, 2018
    Messages:
    5
    Likes Received:
    2

    -Return to Top-

    I downloaded the latest update and tried several times to get Arsenal to work with my X-T1, but no luck. It still finds the arsenal device, but then reports that it can't find the device. At one point I voiced frustration when I was communicating with their tech support. I was given the option for a refund and a postage mailer. I think I'm very close to taking them up on their offer...
     

Share This Page

  1. fujix-forum.com uses cookies to help personalize content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice